Where is all the software & how to install it (snap?)?

I am new to Almalinux and am struggling to find and install relevant software which I use frequently.

When I look into the software center, it is almost empty. I cant find a way to search for what is available rather than what is already installed.

At the moment I want to install qt5 and gcc and all the supporting packages to compile technical applications. A webpage suggests to install a qt5 snap package - is that the way to do it? Where/How to find and install all linux software? How to check what is already installed?

do not use snap, if you do that then you may as well be using archlinux or something, you will have defeated the point of using an enterprise-grade distro. ditch whatever website told you to do that.

dnf install qt5 gcc” is what you want.

dnf search qt5” would have helped you find it.

rpm -q qt5” will tell you if its already installed.

software center is useless, don’t bother with the gui apps.

if you use the software frequently then what distro have you come from?

rpm -qa
dnf list installed

Alma has what RHEL has and RHEL does not have everything and then some.
There are third-party repositories that have for EL what EL does not have.

The most prominent is EPEL (Extra Packages for Enterprise Linux).
That repo is relatively safe, and easy to get access to:

sudo dnf install epel-release

Thank you for the quick responses!

@ sej7278: I have been using Solus Linux (stable, performant, current, easy to use) for the past 5 years, replacing Ubuntu which had reliability problems at the time after a rushed update cycle as I would call it. I have been using Redhat Linux in its early days for many years before it became RHEL. Now I am replacing Solus Linux as I want to port some scientific applications to run on AMD GPUs and need AMD Rocm which will hopefully soon be available for RHEL i.e. Almalinux 9. It would probably be too much effort required to install Rocm on Solus.

I don’t know Rocm.

The gcc is just one package. Installing it will probably install some other packages that gcc depends on, but probably not “all the supporting” set. (For example, gcc does not require gcc-c++ and Qt is a C++ framework.)

There are some predefined sets of packages, “groups” though for convenience. To see groups:

dnf group list
dnf group list --hidden

Among those lists is “Development Tools”. To see what it contains:

dnf group info -v "Development Tools"

The ‘-v’ option adds the “source repo”, where the package comes from. If repo’s name starts with ‘@’ then package is already installed.

To install that group:

sudo dnf group install "Development Tools"

The ‘qt5’ does not belong to any group:

$ dnf repoquery --groupmember qt5
Last metadata expiration check: 2:09:47 ago on Tue 12 Jul 2022 07:41:43 PM EEST.

It is actually a “metapackage” – has practically no files, but requires other packages:

dnf info qt5
dnf repoquery -l qt5
dnf repoquery --requires qt5

However, there are other qt5-relates packages too:

dnf list qt5\*

second that ! never worked the way it was billed - just left me with loads of crap to clear out.

some things I use…

dnf list available
dnf list available | grep -i thingamajig
dnf list available > stuff-I-can-get.txt

of course that only covers stuff in your repos and not everything is in repos, you may need to download an rpm and install it from that

You may have repos which are disabled too.
dnf repolist --all
Powertools stands out as one to enable…
dnf config-manager --enable powertools

Building software on linux is often not straight forward because distros can change the underlying code leading to binary/lib/api incompatabilities and what will build with no intervention on one distro will not build on another without a lot of effort - very often far far far too much effort.

There is another approach where a package is not easily available on your chosen OS - use multiple OSes either with multiple boot (via the bios/uefi not the loader) or more practically with virtual machines.

I needed Bugzilla on a server but it is not available for RHEL so I run a Fedora Server as a VM on a RL host because Fedora includes Bugzilla in its repos. There’s loads of MultiMedia stuff you would spend your life getting to work on RHEL but Ubuntu Studio has it all so I have a separate disk to boot that from when I need it (with access to the other disks if I need those) - bit of a pain and would run as a VM but you can’t get the latency. MS Office ! You just CANNOT get Excel on ANY linux distro :slight_smile: …so I run Windows as a VM on my RL Workstation and can switch as easily as switching to another app.

FWIW, I find several packages that I like missing on Alma9. As it’s just testing for me right now, I play with building packages from srpms. Most, though not all the time, I can take an FC34 srpm and successfully rebuild it for Alma. I’ve done this with weechat ( had to edit the specfile), tint2, and zathura-pdf-mupdf, and mplayer. along with some dependencies, usually found with sudo dnf builddep, . If using alma9, what was powertools is now crb, enabled with sudo dnf config-manager --enable crb. (CRB stands for code ready builder).
There’s a bunch of articles on building srpms, I have my own, rather sparse page, at Building rpms


I use https://pkgs.org/ & Welcome to the RPM repository on fr2.rpmfind.net to find in which repo the RPM could be. If not in any repo I look in https://src.fedoraproject.org/ . If it’s in Fedora but not in EPEL I open a bugzilla ticket to branch and build the software for my required EPEL branch. If I don’t receive any response I build my own package from latest Fedora stable branch and do patches if required.