Wifi adapter in laptop but not accessible on AlmaLinux

Hello everyone,

Maybe a tricky question but hopefully not so much :slight_smile:

So my laptop has a wireless card, but AlmaLinux can’t see it: in the Gnome interface, I can’t switch Wi-Fi (“No Wifi adapter found”).

However, if I run

  • hwinfo --pci,
    I can see that, indeed, there is a Wifi adapter on this laptop.

My understanding is that this situation stems from BIOS (that’s the tricky part, may detail that if needed), and I try to found any way to re-activate Wifi from CLI or elsewhere.

Then I tried

  • nmcli radio wifi on
  • nmcli radio all on
    but still, I can’t see the Wifi adapter in Gnome.

Therefore, I would like to access, and possibly update, the BIOS configuration items in the laptop running AlmaLinux.

To access this information, I tried those commands:

  • dmidecode
  • hwinfo

But how could I update the Wifi (Wireless) adapter flag in the BIOS from AlmaLinux ?

Many thanks !

Run lspci -nn. The output for each device does contain Device ID. It looks like [1234:89ab].
What is the ID for your adapter?

Hi @jlehtone,

Many thanks for the quick response!

The device id is: [ 10ec : c821 ] (Realtek)

As you did notice, the stock kernel does not have a driver for it:

$ modprobe -c | grep -i 10ec.*c821

The next place to look for is ELRepo: HTML Redirect
Alas, not there either. (ELRepo has drivers that Red Hat has chosen not to include in RHEL.)

Wider websearch this this: Realtek Semiconductor RTL8821CE 802.11ac PCIe Wireless Network Adapter that writes:

The device is supported by kernel versions 5.9 and newer according to the LKDDb

That leaves two options that might work:

  1. Use kernel-ml from ELRepo HTML Redirect (assuming you now have AlmaLinux 8)
  2. Install AlmaLinux 9 that was released last week

Hi @jlehtone, many thanks for the response and for sharing these great resources, much appreciated!

By the way, @jlehtone, would you have a suggestion please about how to check BIOS / EFI parameters from AlmaLinux? (nb: it’s understood advanced settings for instance should be handled with care, and I am thinking of reading/dumping these settings, logs, etc.).

I further searched the topic and found for instance the efitools package, with the manual here:

Wondering if there is already a similar tool installed in RHEL/AlmaLinux or which could be installed?

I know of efibootmgr and mokutil that are installed by default in EFI system.

There is also /sys/firmware/efi that I presume the tools to read.

Ah, dnf list \*efi\* does list package efivar (among other things).

1 Like

Big thanks to you @jlehtone !