WOL (wake on lan)

Hello together

we are using a Raspberry pi 4 as a kiosk browser on it. This decision has been made because of using RHEL on all our other servers. It’s working great and I’m pleased with that.
In terms of the Energie crises here in Europe, we need now to power down these little servers (also with some other big ones) to save energy. A shutdown works great with a little script and a cronjob. But we like to power the server up again with a “wake on Lan” call.

But I can’t enable WOL on the network card on these raspberry pi 4 's.
If I try to enable WOL on the interface I get:

→ ethtool -s eth0 wol pumbag
netlink error: cannot enable unsupported WoL mode (offset 36)
netlink error: Invalid argument

if I do a check of the network device I get:

→ ethtool eth0
Supports Wake-on: d
Wake-on: d

And also my entry in the network config itself doesn’t help.
→ ETHTOOL_OPTS=“wol g”

Does one of you maybe have an idea of how to solve this issue?

best regards and thank you


pretty sure the pi’s don’t support WOL, there may be a hat (PoE?) that could do similar but its hardly worth it with what little power they suck - the screen its displaying on would use more juice so you could try turning it off using dpms or suchlike.

otherwise what about a timer/smart socket for the mains power?