Yum auto update reboot

Hello everyone,

I discovered that my server running with Alma have yum automatic update by default via cockpit.
There’s an other way to disable them, and to not reboot the server after update ?

I tried to check :

systemctl cat dnf-automatic.timer

I found

rm of it with

systemctl daemon-reload

When i do one migration from Centos8 to Alma, is it possible to desactivate this auto reboot with an option ?

Many thanks

On my system, which was installed as Alma 8.3 rather than migrated, I do not have /etc/dnf/automatic.conf at all. Systemd doesn’t know anything about the timer and there is no /etc/systemd/system/dnf-automatic-install.service.d directory.

In cockpit, scroll down into the tools section and you should see “Software Updates” as one tool. Click on it and there is the option there to set up (on my machine) automatic updates. You ought to be able to turn them off there.

On a system that was migrated from CentOS Linux 8.4 into AlmaLinux 8:

# dnf -q provides /etc/dnf/automatic.conf
dnf-automatic-4.4.2-11.el8.noarch : Package manager - automated upgrades
Repo        : baseos
Matched from:
Filename    : /etc/dnf/automatic.conf

That file is provided by package dnf-automatic, which is not installed.
That package would create files:

# dnf -q repoquery -l dnf-automatic


# dnf -q provides /etc/systemd/system/dnf-automatic-install.service.d
Error: No Matches found

The /etc/systemd/system/dnf-automatic-install.service.d/ and its contents are not from the package, but local customizations that would augment/override the service defaults.

# dnf -q repoquery --whatrequires dnf-automatic

Nothing seems to require the package either. If you have the package installed and customized config, then you have installed&created them, perhaps via cockpit?

The migrate script pleads: not guilty.

Thanks for the help, you have right, i already got

rpm -qa |grep dnf-automatic-4.4.2-11.el8.noarch

on my centos8 template, i need to correct this