Zoom screen share not working on AlmaLinux 9.1


I can’t share the screen when using Zoom. My system is up to date and I updated Zoom to the latest version available on the Zoom website. The “error” message is about Wayland support but it says RHEL 8+ are supported.

It worked last week before the update to Almalinux 9.1 so I assume there is an issue with that.

It’s the same issue when using the webclient, I can’t share the screen.

I did notice the same last week, Tuesday, before 9.1.
I was able to share screen after I logged out of the Wayland session and logged in X11 session.

Both Gnome, NVidia card with nouveau driver.

Thank you, it works with X11 for me as well so it’s probably a Wayland related problem again.

I would not call it “Wayland issue”. Not a technical issue.

The Zoom clearly “has a list” and is pedantic about it. They should add Alma to that list. The only question is, who should tell them?

I am not so sure:

When I first installed Zoom, I got a SELinux error when I tried to run it, then Wayland was not supported as far as screen sharing is concerned, their update fixed it (for some time), it stopped working last week after an AlmaLinux 9.0 update (when I was still with the same Zoom version), after the AlmaLinux 9.1. update, the problem remained, after updating to the latest RHEL Zoom version, the problem is still there. Zoom seems to have a weak point that causes Wayland related issues and the root cause is not on the testing checklist. This time, it appears to me, that the update introduced the problem.

i can screenshare but not unshare - when i unshare and someone else shares, i still see my desktop not there’s, until i exit and rejoin. x11 on debian sid (other people i know have the same issue on fedora). zoom 5.12.9 (367)

Has anybody managed to share the screen on AlmaLinux 9? I am on 9.3 and I couldn’t with neither the RPM or the Flatpak version of zoom.

Yes, with RPM-version. Just today I did share successfully.
Version on AlmaLinux 9.3,
Gnome X11 session with proprietary NVidia driver.

I forgot to add that I am using GNOME on Wayland, the default. Don’t forget, X11 is basically dead.

no its still broken, you can share a window or tab sometimes, but generally not a monitor or screen when using wayland (5.16.10-668 for debian)

so it kind of works with wayland, but x11 is better supported.