Almalinux 9 Network Problem

With Almalinux my server has no network connection.
I tried Alma 8 and 9.

In installer, it can be connect to network but after the installation complete and boot from OS , there is no network adapter.

lspci -nn | grep -i net does show the device ID of network cards. For example: [8086:15b8]
The ID is most precise way to describe the hardware.

If installer can use network, then driver support does exists and issue is in config.
You can see the interface devices and configured connections with:

nmcli d s
nmcli c s
1 Like

In nmcli there is no other devices except loopback adapter.
Im using minimal iso for installation.

Here is the output for nmcli commands,

so there’s 2 ethernet devices there, do they have a cable connected to a router/switch? (are they up)

1 Like

I think its driver issue, in WinServer and other RHEL network working. Its not working on Alma.

The screenshot shows two defined connections, but no devices for them. The installer does create connection definitions for the devices that it does see.

The question is why the installed system does not show the devices. The boot should enumerate devices and load drivers for each.

The pciutils is in ‘appstream’ and hence not on the “minimal install image”.

The CentOS 7 installation has ‘lspci’, so it can show the device ID?

If the Alma installer does have network, then one could choose installer’s console view and there look at what driver is used by the devices. Load same driver (with modprobe) within the installed Alma to see what happens there.

1 Like

Thanks for your reply.
Device ID from Centos,
BCM57840 NetXtreme II 10/20-Gigabit Ethernet [14e4:16a2] (rev 11)

Sorry but in installer keyboard not working. I didnt check. In centos and alma 8.6 its using bnx2x driver.

Ok, i think i found.
In 8.7 and 9 no bnx2x driver for network card. I tried to install but its not working.
How can i install ?
But in 8.6 its ok.

What is the device ID?

Both 8.7’s and 9.1’s kernels do have the ‘bnx2x’ module.

1 Like

When i enter in Alma 8.7 or latest 9, modinfo bnx2x or modprobe bnx2x its says not found. (its like not found in /lib/modules… error).

Device ID is ,
06:00.0 Ethernet controller [0200]: Broadcom Inc. and subsidiaries BCM57840 NetXtreme II 10/20-Gigabit Ethernet [14e4:16a2] (rev 11)

06:00.1 Ethernet controller [0200]: Broadcom Inc. and subsidiaries BCM57840 NetXtreme II 10/20-Gigabit Ethernet [14e4:16a2] (rev 11)

You do have package kernel-modules installed?

1 Like

Package ‘kernel’ requires ‘kernel-modules’, so it should be in the minimal install.

The bnx2x is in kernel-modules. That package is in baseos. If it is not installed, then you at least should be able to (re)install it from the installer’s media.

1 Like

But i installed with default settings.

With default 8.6 its working,
With default 8.7 its not working.
I think its about Almalinux problem.
I tried different isos with couple time.

Can you show us the output from:

$ rpm -ql kernel-modules | grep bnx2x

1 Like

It seems kernel-modules not installed.
Its minimal Alma 8.7 .

Can you somehow download the kernel-module package if it is not in the install media. You need this package for the bnx2x kernel module.

1 Like

well the 8.7 minimal iso definitely has the kernel-modules-4.18.0-425.3.1.el8.x86_64.rpm package in it, so you have either removed it or have a corrupt download.

you could download it from here:

inside that is /lib/modules/4.18.0-425.3.1.el8.x86_64/kernel/drivers/net/ethernet/broadcom/bnx2x/bnx2x.ko.xz

1 Like

I just looked at the contents of the minimal iso file. It does include the kernel-modules package. So you can pull it from there, too.


1 Like

@sej7278 replied before I did. :wink:

1 Like